Search This Blog

Friday, January 7, 2011

Solaris Commands

Few Useful Solaris Commands


To Display System Memory:
prtconf | grep Memory

To Display process utilizing high cpu
ps -eo pid,pcpu,args | sort +1n | tail -3

To Display process utilizing high memory
ps -eo pid,vsz,args | sort +1n | tail -3

To find Processor Type and Speed
% psrinfo -v

To Find out a package which a file belongs to
pkgchk -l -p /usr/lib/sendmail 

To Find System configuration
/usr/platform/`uname -i`/sbin/prtdiag

Display the device list (and drivers attached to devices)
prtconf -D

Command to Check whether it is 32 or 64 bit OS
isalist -v