Few Useful Solaris Commands
To Display System Memory:
prtconf | grep Memory
To Display process utilizing high cpu
ps -eo pid,pcpu,args | sort +1n | tail -3
To Display process utilizing high memory
ps -eo pid,vsz,args | sort +1n | tail -3
To find Processor Type and Speed
% psrinfo -v
To Find out a package which a file belongs to
pkgchk -l -p /usr/lib/sendmail
To Find System configuration
/usr/platform/`uname -i`/sbin/prtdiag
Display the device list (and drivers attached to devices)
prtconf -D
Command to Check whether it is 32 or 64 bit OS
isalist -v
Middleware
This Blog will have useful information on Linux/Solaris/AIX/IHS/Websphere/MQ
Search This Blog
Friday, January 7, 2011
JKS
Creating a certificate in a Java keyStore
keytool -genkey -dname "cn=JavaCertName, ou=Department, o=Company, c=GB, st=StateOrCounty" -alias MyClient -storepass changeit -keypass changeit -keyStore keyStore
Creating a certificate request file from the newly created certificate
keytool -certreq -keystore keyStore -storepass changeit -keypass changeit -alias MyClient -file MyClient.crs
Command to Import the signed certificate
keytool -import -keystore keyStore -storepass changeit -alias MySignedClient -keypass changeit -import -file MyClient.cer
keytool -genkey -dname "cn=JavaCertName, ou=Department, o=Company, c=GB, st=StateOrCounty" -alias MyClient -storepass changeit -keypass changeit -keyStore keyStore
Creating a certificate request file from the newly created certificate
keytool -certreq -keystore keyStore -storepass changeit -keypass changeit -alias MyClient -file MyClient.crs
Command to Import the signed certificate
keytool -import -keystore keyStore -storepass changeit -alias MySignedClient -keypass changeit -import -file MyClient.cer
Subscribe to:
Posts (Atom)